Persistent Brake Problem - 2019 Scamp 13

5 posts / 0 new
Last post
Scamp Duo
Offline
Last seen: 2 weeks 6 days ago
Lifetime Member
Joined: 06/24/2018 - 19:21
Persistent Brake Problem - 2019 Scamp 13

Our Scamp 13 has the brakes and controller (Autowbrake) installed by Eveland.  Everything works fine heading out, but after about 2 hours of use and when driving at < 20mph, the brakes lock up and the tires skid when braking.  No problems when braking at > 30mph.

We've been to a reputable RV repair place 3 times, and worked with Autowbrake twice.  It's not a controller issue, and the controller is at the lowest setting.

Has anybody run into this?

Thanks!

salukispeed
Offline
Last seen: 16 hours 1 min ago
Joined: 08/20/2018 - 13:45
I have

I have seen my 2019 be somewhat aggresive if the brake shoe adjustment is not correct. and the closer to the tight side of the adjustment the more controllable and Happier ours is. On my Redarc controler the adjustment is usually at 3.5 out of 10  and somewhat sensitive but i can turn it down low enough that it does not do anything. It sounds that the adjustment should be able to go lower

2019 Scamp 13 standard

Scamp Duo
Offline
Last seen: 2 weeks 6 days ago
Lifetime Member
Joined: 06/24/2018 - 19:21
Interesting! Feedback I'm

Interesting! Feedback I'm getting elsewhere leans toward the brakes being too tight. If loosening doesn't do it, then I'll try tightening.

An Autowbrake technician advised me to check the voltage going into as well as out of the controller. Input was >12V. The desired output is less than 1V, and my multimeter showed ~0.5V. Furthermore, the controller is on setting 1 (for trailers <3500 lb) and gain is 0 (levels are 0-6). So the controller is working, and it's at the lowest possible setting.

salukispeed
Offline
Last seen: 16 hours 1 min ago
Joined: 08/20/2018 - 13:45
Wonder

Sometimes I cant help wonder if the brakes are one size too big for a 1500 lb trailer.  

2019 Scamp 13 standard

Mr.T
Mr.T's picture
Offline
Last seen: 4 hours 42 min ago
Joined: 07/21/2020 - 12:22
Despite the previous trips to

Despite the previous trips to the RV place, I think it's the brakes themselves.  Since they are fine until after 2 hours of driving, it points to a problem after they heat up.  They might be too tight, and should rotate without any dragging sound when jacked off the ground.  The shoes could be contaminated with oil/grease as well.

On our 2021 13' we have the same controller on the same settings, and no skidding even when manually braking using the fob remote and no tow vehicle braking.  I've increased the gain, and it still won't skid a tire in normal operation.  However, it will skid when manually applying trailer brakes (without tow vehicle brakes) using the fob at higher gain settings on wet pavement, but I attribute this to a 1750 pound trailer (axle weight) trying to stop a much heavier 5000 pound tow vehicle.